import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(class|struct|enum|extension)[\\h\\S]*\\{$\\n(?!\\s)";
final String string = "// should trigger\n"
+ "public final class Aaaaaaa {\n"
+ "var cat: Bool\n"
+ "}\n\n"
+ "// should not trigger\n"
+ "class Aaa {\n\n"
+ "var cat: Bool\n"
+ "}\n\n"
+ "// should not trigger\n"
+ "func bbb {\n"
+ "}\n\n"
+ "// should trigger\n"
+ "struct Ccc {\n"
+ "}\n\n"
+ "// should not trigger\n"
+ "struct Ccc {\n\n"
+ "}\n\n"
+ "// should trigger\n"
+ "enum Ddd {\n"
+ "}\n\n"
+ "// should not trigger\n"
+ "enum Ddd {\n\n"
+ "}\n\n"
+ "// should trigger\n"
+ "extension Eee {\n"
+ "}\n\n"
+ "// should not trigger\n"
+ "extension Eee {\n\n"
+ "}\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}