import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?'number'(?'float'(?>\\d+[\\.](?>\\d+)?)|(?>(?>\\d+)?[\\.]\\d+))|\\d+)(?'exponent'e[+-](?&number))?";
final String string = " 2.0 \n"
+ " .0 \n"
+ " 3. \n"
+ " 2e+1 \n"
+ " 2.0e+1 \n"
+ " 2.123e+1.2 \n"
+ "2\n"
+ "5\n"
+ " 2 2 4 5 6\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}