import re
regex = re.compile(r"(?'number'(?'float'(?>\d+[\.](?>\d+)?)|(?>(?>\d+)?[\.]\d+))|\d+)(?'exponent'e[+-](?&number))?", flags=re.MULTILINE)
test_str = (" 2.0 \n"
" .0 \n"
" 3. \n"
" 2e+1 \n"
" 2.0e+1 \n"
" 2.123e+1.2 \n"
"2\n"
"5\n"
" 2 2 4 5 6\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")