use strict;
my $str = ' 2.0
.0
3.
2e+1
2.0e+1
2.123e+1.2
2
5
2 2 4 5 6
';
my $regex = qr/(?'number'(?'float'(?>\d+[\.](?>\d+)?)|(?>(?>\d+)?[\.]\d+))|\d+)(?'exponent'e[+-](?&number))?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}