$re = '/(?\'number\'(?\'float\'(?>\d+[\.](?>\d+)?)|(?>(?>\d+)?[\.]\d+))|\d+)(?\'exponent\'e[+-](?&number))?/m';
$str = ' 2.0
.0
3.
2e+1
2.0e+1
2.123e+1.2
2
5
2 2 4 5 6
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);