using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Security information[\r\n]*Nett sales:[\r\n]+([^\r\n]+)";
string input = @"some
text
goes here
here
Security information
here
and here
Security information
Nett sales:
15333.40
text after this too
here
Nett sales:
here
Security information
Nett sales:1343556
here too 1234 88475 page1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}