import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Security information[\\r\\n]*Nett sales:[\\r\\n]+([^\\r\\n]+)";
final String string = "some\n"
+ "text\n"
+ "goes here\n"
+ "here\n"
+ "Security information\n"
+ "here\n"
+ "and here\n"
+ "Security information\n"
+ "Nett sales:\n"
+ "15333.40\n"
+ "text after this too\n"
+ "here\n"
+ "Nett sales:\n\n"
+ "here\n\n"
+ "Security information\n"
+ "Nett sales:1343556\n"
+ "here too 1234 88475 page1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}