# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Security information[\r\n]*Nett sales:[\r\n]+([^\r\n]+)"
test_str = ("some\n"
"text\n"
"goes here\n"
"here\n"
"Security information\n"
"here\n"
"and here\n"
"Security information\n"
"Nett sales:\n"
"15333.40\n"
"text after this too\n"
"here\n"
"Nett sales:\n\n"
"here\n\n"
"Security information\n"
"Nett sales:1343556\n"
"here too 1234 88475 page1")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.