$re = '/Security information[\r\n]*Nett sales:[\r\n]+([^\r\n]+)/m';
$str = 'some
text
goes here
here
Security information
here
and here
Security information
Nett sales:
15333.40
text after this too
here
Nett sales:
here
Security information
Nett sales:1343556
here too 1234 88475 page1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);