use strict;
my $str = 'some
text
goes here
here
Security information
here
and here
Security information
Nett sales:
15333.40
text after this too
here
Nett sales:
here
Security information
Nett sales:1343556
here too 1234 88475 page1';
my $regex = qr/Security information[\r\n]*Nett sales:[\r\n]+([^\r\n]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}