package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Security information[\r\n]*Nett sales:[\r\n]+([^\r\n]+)`)
var str = `some
text
goes here
here
Security information
here
and here
Security information
Nett sales:
15333.40
text after this too
here
Nett sales:
here
Security information
Nett sales:1343556
here too 1234 88475 page1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}