#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?<email>[\w._+-]+@[\w.-]+\.\w+)\b"
Local $sString = "this is a test1@example1.com test content with multiple test2@example2.com email addresses" & @CRLF & _
"" & @CRLF & _
"this is a test3@example3.com test content with multiple test4@example4.com email addresses" & @CRLF & _
"" & @CRLF & _
"test.er+test@experts.make.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")