const regex = /\b(?<email>[\w._+-]+@[\w.-]+\.\w+)\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?<email>[\\w._+-]+@[\\w.-]+\\.\\w+)\\b', 'gm')
const str = `this is a test1@example1.com test content with multiple test2@example2.com email addresses
this is a test3@example3.com test content with multiple test4@example4.com email addresses
test.er+test@experts.make.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}