// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(?<email>[\w._+-]+@[\w.-]+\.\w+)\b").unwrap();
let string = "this is a test1@example1.com test content with multiple test2@example2.com email addresses
this is a test3@example3.com test content with multiple test4@example4.com email addresses
test.er+test@experts.make.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}