use strict;
my $str = 'this is a test1@example1.com test content with multiple test2@example2.com email addresses
this is a test3@example3.com test content with multiple test4@example4.com email addresses
test.er+test@experts.make.com';
my $regex = qr/\b(?<email>[\w._+-]+@[\w.-]+\.\w+)\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}