import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?<email>[\\w._+-]+@[\\w.-]+\\.\\w+)\\b";
final String string = "this is a test1@example1.com test content with multiple test2@example2.com email addresses\n\n"
+ "this is a test3@example3.com test content with multiple test4@example4.com email addresses\n\n"
+ "test.er+test@experts.make.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}