$re = '/\b(?<email>[\w._+-]+@[\w.-]+\.\w+)\b/m';
$str = 'this is a test1@example1.com test content with multiple test2@example2.com email addresses
this is a test3@example3.com test content with multiple test4@example4.com email addresses
test.er+test@experts.make.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);