package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?<email>[\w._+-]+@[\w.-]+\.\w+)\b`)
var str = `this is a test1@example1.com test content with multiple test2@example2.com email addresses
this is a test3@example3.com test content with multiple test4@example4.com email addresses
test.er+test@experts.make.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}