# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/"value":"[^"]+"/"value":""/gm;t' <<< "{
\"value\":\"93827364\"
},
{
\"value\":\"72653423\"
},
{
\"value\":\"37369425\"
},
{
\"value\":\"59026204\"
}"