import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"value\":\"[^\"]+\"";
final String string = "{\n"
+ " \"value\":\"93827364\"\n"
+ "},\n"
+ "{\n"
+ " \"value\":\"72653423\"\n"
+ "},\n"
+ "{\n"
+ " \"value\":\"37369425\"\n"
+ "},\n"
+ "{\n"
+ " \"value\":\"59026204\"\n"
+ "}";
final String subst = "\"value\":\"\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}