#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?:banner|ipm|trace|edf|versioncheck|iploc|p(?:ki|roxy(?:-detection)?)|h[1,3]-weblb01-v)\.eset\.com$"
Local $sString = "iploc.eset.com" & @CRLF & _
"versioncheck.eset.com" & @CRLF & _
"edf.eset.com" & @CRLF & _
"trace.eset.com" & @CRLF & _
"ipm.eset.com" & @CRLF & _
"banner.eset.com" & @CRLF & _
"pki.eset.com" & @CRLF & _
"proxy.eset.com" & @CRLF & _
"proxy-detection.eset.com" & @CRLF & _
"h1-weblb01-v.eset.com" & @CRLF & _
"h3-weblb01-v.eset.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")