// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^(?:banner|ipm|trace|edf|versioncheck|iploc|p(?:ki|roxy(?:-detection)?)|h[1,3]-weblb01-v)\.eset\.com$").unwrap();
let string = "iploc.eset.com
versioncheck.eset.com
edf.eset.com
trace.eset.com
ipm.eset.com
banner.eset.com
pki.eset.com
proxy.eset.com
proxy-detection.eset.com
h1-weblb01-v.eset.com
h3-weblb01-v.eset.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}