$re = '/^(?:banner|ipm|trace|edf|versioncheck|iploc|p(?:ki|roxy(?:-detection)?)|h[1,3]-weblb01-v)\.eset\.com$/mi';
$str = 'iploc.eset.com
versioncheck.eset.com
edf.eset.com
trace.eset.com
ipm.eset.com
banner.eset.com
pki.eset.com
proxy.eset.com
proxy-detection.eset.com
h1-weblb01-v.eset.com
h3-weblb01-v.eset.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);