using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:banner|ipm|trace|edf|versioncheck|iploc|p(?:ki|roxy(?:-detection)?)|h[1,3]-weblb01-v)\.eset\.com$";
string input = @"iploc.eset.com
versioncheck.eset.com
edf.eset.com
trace.eset.com
ipm.eset.com
banner.eset.com
pki.eset.com
proxy.eset.com
proxy-detection.eset.com
h1-weblb01-v.eset.com
h3-weblb01-v.eset.com";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}