re = /^(?:banner|ipm|trace|edf|versioncheck|iploc|p(?:ki|roxy(?:-detection)?)|h[1,3]-weblb01-v)\.eset\.com$/mi
str = 'iploc.eset.com
versioncheck.eset.com
edf.eset.com
trace.eset.com
ipm.eset.com
banner.eset.com
pki.eset.com
proxy.eset.com
proxy-detection.eset.com
h1-weblb01-v.eset.com
h3-weblb01-v.eset.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end