import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:banner|ipm|trace|edf|versioncheck|iploc|p(?:ki|roxy(?:-detection)?)|h[1,3]-weblb01-v)\\.eset\\.com$";
final String string = "iploc.eset.com\n"
+ "versioncheck.eset.com\n"
+ "edf.eset.com\n"
+ "trace.eset.com\n"
+ "ipm.eset.com\n"
+ "banner.eset.com\n"
+ "pki.eset.com\n"
+ "proxy.eset.com\n"
+ "proxy-detection.eset.com\n"
+ "h1-weblb01-v.eset.com\n"
+ "h3-weblb01-v.eset.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}