#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([0-9]*) ?(.|BIS|TER|QUATER)? (.*)$"
Local $sString = "10 A RUE DE LA MAIRIE" & @CRLF & _
"8 RUE DE LA PLAINE" & @CRLF & _
"4 BIS PLACE DES TILLEULS" & @CRLF & _
"10B ALLE DES PINS" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")