package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([0-9]*) ?(.|BIS|TER|QUATER)? (.*)$`)
var str = `10 A RUE DE LA MAIRIE
8 RUE DE LA PLAINE
4 BIS PLACE DES TILLEULS
10B ALLE DES PINS
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}