// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([0-9]*) ?(.|BIS|TER|QUATER)? (.*)$").unwrap();
let string = "10 A RUE DE LA MAIRIE
8 RUE DE LA PLAINE
4 BIS PLACE DES TILLEULS
10B ALLE DES PINS
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}