use strict;
my $str = '10 A RUE DE LA MAIRIE
8 RUE DE LA PLAINE
4 BIS PLACE DES TILLEULS
10B ALLE DES PINS
';
my $regex = qr/^([0-9]*) ?(.|BIS|TER|QUATER)? (.*)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}