$re = '/^([0-9]*) ?(.|BIS|TER|QUATER)? (.*)$/m';
$str = '10 A RUE DE LA MAIRIE
8 RUE DE LA PLAINE
4 BIS PLACE DES TILLEULS
10B ALLE DES PINS
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);