re = /^([0-9]*) ?(.|BIS|TER|QUATER)? (.*)$/m
str = '10 A RUE DE LA MAIRIE
8 RUE DE LA PLAINE
4 BIS PLACE DES TILLEULS
10B ALLE DES PINS
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end