import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([0-9]*) ?(.|BIS|TER|QUATER)? (.*)$";
final String string = "10 A RUE DE LA MAIRIE\n"
+ "8 RUE DE LA PLAINE\n"
+ "4 BIS PLACE DES TILLEULS\n"
+ "10B ALLE DES PINS\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}