#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?u)Next Candidate[^\w]+(\w+)\h+(\w+)[^\d\(]+([\d\.\- \(\)]+)"
Local $sString = "Next Candidate" & @CRLF & _
"" & @CRLF & _
"FirstName LastName" & @CRLF & _
"" & @CRLF & _
"845-728-1111" & @CRLF & _
"Applied" & @CRLF & _
"" & @CRLF & _
"or this way" & @CRLF & _
"" & @CRLF & _
"Next Candidate" & @CRLF & _
"FirstName LastName" & @CRLF & _
"845-728-1111" & @CRLF & _
"Applied" & @CRLF & _
"" & @CRLF & _
"Next Candidate" & @CRLF & _
"FirstName LastName" & @CRLF & _
"(845) 728-1111" & @CRLF & _
"Applied"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")