const regex = /Next Candidate[^\w]+(\w+)\h+(\w+)[^\d\(]+([\d\.\- \(\)]+)/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Next Candidate[^\\w]+(\\w+)\\h+(\\w+)[^\\d\\(]+([\\d\\.\\- \\(\\)]+)', 'gu')
const str = `Next Candidate
FirstName LastName
845-728-1111
Applied
or this way
Next Candidate
FirstName LastName
845-728-1111
Applied
Next Candidate
FirstName LastName
(845) 728-1111
Applied`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}