using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Next Candidate[^\w]+(\w+)\h+(\w+)[^\d\(]+([\d\.\- \(\)]+)";
string input = @"Next Candidate
FirstName LastName
845-728-1111
Applied
or this way
Next Candidate
FirstName LastName
845-728-1111
Applied
Next Candidate
FirstName LastName
(845) 728-1111
Applied";
RegexOptions options = RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}