import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Next Candidate[^\\w]+(\\w+)\\h+(\\w+)[^\\d\\(]+([\\d\\.\\- \\(\\)]+)";
final String string = "Next Candidate\n\n"
+ "FirstName LastName\n\n"
+ "845-728-1111\n"
+ "Applied\n\n"
+ "or this way\n\n"
+ "Next Candidate\n"
+ "FirstName LastName\n"
+ "845-728-1111\n"
+ "Applied\n\n"
+ "Next Candidate\n"
+ "FirstName LastName\n"
+ "(845) 728-1111\n"
+ "Applied";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}