package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Next Candidate[^\w]+(\w+)\h+(\w+)[^\d\(]+([\d\.\- \(\)]+)`)
var str = `Next Candidate
FirstName LastName
845-728-1111
Applied
or this way
Next Candidate
FirstName LastName
845-728-1111
Applied
Next Candidate
FirstName LastName
(845) 728-1111
Applied`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}