$re = '/Next Candidate[^\w]+(\w+)\h+(\w+)[^\d\(]+([\d\.\- \(\)]+)/u';
$str = 'Next Candidate
FirstName LastName
845-728-1111
Applied
or this way
Next Candidate
FirstName LastName
845-728-1111
Applied
Next Candidate
FirstName LastName
(845) 728-1111
Applied';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);