// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?u)Next Candidate[^\w]+(\w+)\h+(\w+)[^\d\(]+([\d\.\- \(\)]+)").unwrap();
let string = "Next Candidate
FirstName LastName
845-728-1111
Applied
or this way
Next Candidate
FirstName LastName
845-728-1111
Applied
Next Candidate
FirstName LastName
(845) 728-1111
Applied";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}