const regex = /[^\n\x20-\x7f]/gmu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\\n\\x20-\\x7f]', 'gmu')
const str = `DELTA DIŞ TİCARET A.Ş.
DELTA DIŞ TİCARET A.Ş.
DELTA DIŞ TİCARET A.Ş.
`;
const subst = `?`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);