use strict;
my $str = 'DELTA DIŞ TİCARET A.Ş.
DELTA DIŞ TİCARET A.Ş.
DELTA DIŞ TİCARET A.Ş.
';
my $regex = qr/[^\n\x20-\x7f]/mup;
my $subst = '?';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";