# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\\/)(?=[^\\/\n]{0,6}path)[^\\/]{10}\\///gm;t' <<< "d:/KeepItSimple/1234path21/WAVs/filename.wav
d:/TryToKeepItSimple/5678path23/WAVs/filename2.wav
d:/Simpler/path567823/WAVs/filename2.wav
d:/TooShort/path56782/WAVs/filename2.wav
d:/TooLong/path5678234/WAVs/filename2.wav
d:/pathNotPresent/5678pat23/f3.wav
"