const regex = /(?<=\/)(?=[^\/\n]{0,6}path)[^\/]{10}\//gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\\/)(?=[^\\\/\\n]{0,6}path)[^\\\/]{10}\\\/', 'gm')
const str = `d:/KeepItSimple/1234path21/WAVs/filename.wav
d:/TryToKeepItSimple/5678path23/WAVs/filename2.wav
d:/Simpler/path567823/WAVs/filename2.wav
d:/TooShort/path56782/WAVs/filename2.wav
d:/TooLong/path5678234/WAVs/filename2.wav
d:/pathNotPresent/5678pat23/f3.wav
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);