import re
regex = re.compile(r"(?<=\/)(?=[^\/\n]{0,6}path)[^\/]{10}\/", flags=re.MULTILINE)
test_str = ("d:/KeepItSimple/1234path21/WAVs/filename.wav\n"
"d:/TryToKeepItSimple/5678path23/WAVs/filename2.wav\n"
"d:/Simpler/path567823/WAVs/filename2.wav\n"
"d:/TooShort/path56782/WAVs/filename2.wav\n"
"d:/TooLong/path5678234/WAVs/filename2.wav\n"
"d:/pathNotPresent/5678pat23/f3.wav\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)