import Foundation
let pattern = #"(?<=\/)(?=[^\/\n]{0,6}path)[^\/]{10}\/"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
d:/KeepItSimple/1234path21/WAVs/filename.wav
d:/TryToKeepItSimple/5678path23/WAVs/filename2.wav
d:/Simpler/path567823/WAVs/filename2.wav
d:/TooShort/path56782/WAVs/filename2.wav
d:/TooLong/path5678234/WAVs/filename2.wav
d:/pathNotPresent/5678pat23/f3.wav
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)