using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\/)(?=[^\/\n]{0,6}path)[^\/]{10}\/";
string substitution = @"";
string input = @"d:/KeepItSimple/1234path21/WAVs/filename.wav
d:/TryToKeepItSimple/5678path23/WAVs/filename2.wav
d:/Simpler/path567823/WAVs/filename2.wav
d:/TooShort/path56782/WAVs/filename2.wav
d:/TooLong/path5678234/WAVs/filename2.wav
d:/pathNotPresent/5678pat23/f3.wav
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}