use strict;
my $str = 'd:/KeepItSimple/1234path21/WAVs/filename.wav
d:/TryToKeepItSimple/5678path23/WAVs/filename2.wav
d:/Simpler/path567823/WAVs/filename2.wav
d:/TooShort/path56782/WAVs/filename2.wav
d:/TooLong/path5678234/WAVs/filename2.wav
d:/pathNotPresent/5678pat23/f3.wav
';
my $regex = qr/(?<=\/)(?=[^\/\n]{0,6}path)[^\/]{10}\//mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";