import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\/)(?=[^\\/\\n]{0,6}path)[^\\/]{10}\\/";
final String string = "d:/KeepItSimple/1234path21/WAVs/filename.wav\n"
+ "d:/TryToKeepItSimple/5678path23/WAVs/filename2.wav\n"
+ "d:/Simpler/path567823/WAVs/filename2.wav\n"
+ "d:/TooShort/path56782/WAVs/filename2.wav\n"
+ "d:/TooLong/path5678234/WAVs/filename2.wav\n"
+ "d:/pathNotPresent/5678pat23/f3.wav\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}