import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<script\\b[^>]*>[\\s\\S]*<\\/script>";
final String string = "<body>\n"
+ " <temlate></template>\n"
+ " <script>\n"
+ " var str = `<script>var html='abc';</script>\n"
+ " <style></style>\n"
+ " `;\n"
+ " </script>\n\n"
+ " <style></style>\n"
+ "</body>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}